None
Multilayer Switching at digidraft.net

Multilayer Switching

2017-06-13

Inter-VLAN

    SVI cannot become active until at least one Layer 2 port assigned to the VLAN has also become active and STP has converged.

 To leave SVI up even when no Layer 2 ports are active on the VLAN

Switch(config-if)# switchport autostate exclude

    The version number describes the number of times the CEF entry has been updated since the table was generated. The epoch number denotes the number of times the CEF table has been flushed and regenerated as a whole. The 10.1.3.0/26 subnet has two next hop router addresses, so the local switch is using per-destination load sharing between the two routers. 

CEF can be accelerated by two variants:

  • Accelerated CEF (aCEF) - CEF located on individual line cards in chassis-based Catalyst switches, only a portion of the FIB is downloaded to them at any time.
  • Distributed CEF (dCEF) - A Layer 3 engine maintains the routing table and generates the FIB, which is then
    dynamically downloaded in full to each of the line cards.

Adjacency table

    It is portion of FIB which consisting of the MAC addresses of nodes that can be reached in a single Layer 2 hop.

Switch# show adjacency [ type member/module/number | vlan vlan-id ] [ summary | detail ]
  • throttling adjacency - during the time that an FIB entry is in the CEF glean state waiting for the ARP resolution, subsequent packets to that host are immediately dropped so that the input queues do not fill and the Layer 3 engine does not become too busy worrying about the need for duplicate ARP requests
  • null adjacency - used to switch packets destined for the null interface
  • drop adjacency - used to switch packets that cannot be forwarded normally. In effect, these packets are dropped without being forwarded. Packets can be dropped because of an encapsulation failure, an unresolved address, an unsupported protocol, no valid route present, no valid adjacency, or a checksum error
Switch# show cef drop
  • discard adjacency - used when packets must be discarded because of an access list or other policy action.
  • punt adjacency - used when packets must be sent to the Layer 3 engine for further processing
Switch# show cef not-cef-switched
CEF Packets passed on to next switching layer
Slot    No_adj    No_encap    Unsupp'ted    Redirect    Receive    Options    Access    Frag
RP    3579706    0                  0                    0              41258564    0            0              0

    where reasons are:

  • No_adj - an incomplete adjacency
  • No_encap - an incomplete ARP resolution
  • Unsupp’ted - unsupported packet features
  • Redirect - ICMP redirect
  • Receive - layer 3 engine interfaces; includes packets destined for IP addresses that are assigned to interfaces on the Layer 3 engine, IP network addresses, and IP broad cast addresses
  • Options - IP options present
  • Access - access list evaluation failure
  • Frag - fragmentation failure

Marking FIB entries

  • CEF glean - ARP entry does not exist
  • CEF glean state - Layer 3 engine must glean the next-hop destination’s MAC address.

Displaying CEF Entry

Switch# show ip cef 10.1.3.0 255.255.255.192 detail
10.1.3.0/26, version 270, epoch 0, per-destination sharing
0 packets, 0 bytes
    via 192.168.1.2, Vlan99, 0 dependencies
        traffic share 1
        next hop 192.168.1.2, Vlan99
        valid adjacency
    via 192.168.1.3, Vlan99, 0 dependencies
        traffic share 1
        next hop 192.168.1.3, Vlan99
        valid adjacency
    0 packets, 0 bytes switched through the prefix
    tmstats: external 0 packets, 0 bytes
    internal 0 packets, 0 bytes

 

Switch# show ip cef adjacency glean
Prefix             Next Hop     Interface
10.1.1.2/32     attached     Vlan101
127.0.0.0/8     attached     EOBC0/0
[output omitted]
Switch# show ip arp 10.1.1.2
Switch# show ip cef 10.1.1.2 255.255.255.255 detail
10.1.1.2/32, version 688, epoch 0, attached, connected
0 packets, 0 bytes
    via Vlan101, 0 dependencies
        valid glean adjacency

DHCP

DHCP negotiation

  • client sends a broadcast DHCP Discover message
  • server replies with a DHCP Offer message
  • client sends a DHCP Request
  • server replies with a DHCP ACK

IPv4 DHCP Server configuration

Switch(config)# ip dhcp excluded-address start-ip end-ip
Switch(config)# ip dhcp pool pool-name
Switch(config-dhcp)# network ip-address subnet-mask
Switch(config-dhcp)# default-router ip-address [ip-address2] [ip-address3 ] ...
Switch(config-dhcp)# lease {infinite | { days [ hours [ minutes ]]}}
Switch(config-dhcp)# exit

Manual Address Binding

    Client identifiers commonly consist of the digits 01 followed by the client’s MAC address. The 01 prefix, indicating that the client uses Ethernet, the client MAC address 0050.b65b.c0b5.

Switch(config)# ip dhcp pool my-pc
Switch(dhcp-config)# host 192.168.1.99 255.255.255.0
Switch(dhcp-config)# client-identifier 0100.50b6.5bc0.b5
Switch(dhcp-config)# exit
Switch(config)# exit

DHCP Options

Option Number Function
43 Location of a wireless LAN controller for lightweight wireless access
points
69 Location of an SMTP server
70 Location of a POP3 mail server
150 Location of a TFTP server for Cisco IP phones
Switch(dhcp-config)# option option-num value

DHCP Relay configuration

Switch(config)# interface vlan5
Switch(config-if)# ip address 192.168.1.1 255.255.255.0
Switch(config-if)# ip helper-address 192.168.199.4
Switch(config-if)# exit

Get IPv6 addresses and parameters

Stateless Autoconfiguration

    A router provides 64 bits from the Layer 3 subnet prefix, while the client appends a 64-bit EUI-64 interface ID. ID consists of the upper half of the interface’s MAC address (24 bits), followed by the hex string FFFE (16 bits), followed by the lower half of the MAC address (24 bits).

    The client can also pick up other necessary information from the router, like the default router address and the  maximum transmission unit (MTU). Router advertisements are sent periodically or the client can request one on-demand to reduce the wait time.

Switch(config)# interface vlan 5
Switch(config-if)# ipv6 address 2001:db8:a::1/64
Switch(config-if)# no shutdown

DHCPv6

Switch(config)# ipv6 dhcp pool pool-name
Switch(config-dhcpv6)# address prefix ipv6-prefix
Switch(config-dhcpv6)# dns-server dns-address
Switch(config-dhcpv6)# domain-name name
Switch(config)# interface type member/module/number
Switch(config-if)# ipv6 address ipv6-address
Switch(config-if)# ipv6 dhcp server pool-name

    DHCPv6 does not allow you to exclude addresses as you can with DHCPv4. As well, you cannot configure manual address bindings with DHCPv6. 

DHCPv6 Lite

    Cisco also offers DHCPv6 Lite, which combines the simplicity of stateless autoconfiguration for address management with the DHCP option management function of DHCPv6.

    After you configure an IPv6 address prefix on the Layer 3 interface, you should reference the DHCPv6 pool and also enter the following interface configuration command. This will inform the clients that options are available via the DHCPv6 Lite server after stateless autoconfig yields a usable IPv6 address.

Switch(config)# ipv6 dhcp pool v6-users
Switch(config-dhcpv6)# dns-server 2001:db8:c12::10
Switch(config-dhcpv6)# domain-name mydomain.com
Switch(config-dhcpv6)# exit
Switch(config)# interface vlan 5
Switch(config-if)# ipv6 address 2001:db8:a::1/64
Switch(config-if)# ipv6 dhcp server v6-users
Switch(config-if)# ipv6 nd other-config-flag
Switch(config-if)# no shutdown

DHCPv6 Relay Agent

Switch(config-if)# ipv6 dhcp relay destination ipv6-address
Leave a Comment: